YourWBB


yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB Lite 1.0.x » [WBB Lite 1.0.x] Hacks und Addons » Themenbeschreibung » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag 35.702 Views | | Thema zu Favoriten hinzufügen
Seiten (8): « vorherige 1 2 3 4 5 6 7 [8]
Neues Thema erstellen Antwort erstellen

Zum Ende der Seite springen Themenbeschreibung 3 Bewertungen - Durchschnitt: 7,003 Bewertungen - Durchschnitt: 7,00
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Pigsel
Mitglied


images/avatars/avatar-5749.gif

Dabei seit: 05.09.11
Beiträge: 718
Fähigkeiten: WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Yelanha
Zitat:
Original von bluebird*
Bei mir schmeißt er nachdem man auf Vorschau geklickt hat auch immer die Themenbeschreibung raus :/ Das HTTP_POST_VARS hab ich allerdings schon umgeändert, und es funktioniert dennoch nicht :/
code:
1:
2:
3:
        $topicdescr = $_POST['subjectdescr'];
	$topicdescr = addslashes(htmlspecialchars($topicdescr));
        $db->query("INSERT INTO bb".$n."_threads (threadid,boardid,topic,iconid,starttime,starterid,starter,lastposttime,lastposterid,lastposter,pollid,important,visible,descr,prefix) VALUES (NULL,'$boardid','".addslashes(htmlspecialchars($topic))."','$iconid','$time','$wbbuserdata[userid]','".addslashes($wbbuserdata[username])."','$time','$wbbuserdata[userid]','".addslashes($wbbuserdata[username])."','$poll_id','$important','".ifelse($board['moderatenew']==10 || $board['moderatenew']==11,0,1)."','".$topicdescr."','".trim($_POST['prefix'])."')");


Gabs hierzu schon eine Lösung, die ich gekonnt überlesen hab trotz drei Mal durchgucken? ^^' Bei mir verschwindet die Themenbeschreibung auch, sobald ich eine Vorschau erstellen lasse.


siehe:
Zitat:
Wer außerdem noch Probleme mit dem Hack Themenbeschreibung hat und alles was mit Umlauten dargestellt wird oder sonst nicht angezeigt wird,habe ich mal folgendes geändert.

newthread.php öffnen und suchen

$topicdescr = $HTTP_POST_VARS['subjectdescr'];
$topicdescr = htmlspecialchars($topicdescr);

# ändern in

$topicdescr = $_POST['subjectdescr'];
$topicdescr = htmlspecialchars_wbb($topicdescr);

modcp.php öffnen und suche nach

$descr = htmlspecialchars($descr);

# ersetze mit

$descr = htmlspecialchars_wbb($descr);


ist im Zuge der Umstellung für die Umlaute entstanden, aber nicht aus meiner Feder, ich darf es aber zitieren Augenzwinkern

__________________
Ein Leben ohne CodeBug's ist ein Leben im Paradies

01.02.17 10:58 Pigsel ist offline E-Mail Finden Als Freund hinzufügen
Yelanha Yelanha ist weiblich
Mitglied


Dabei seit: 22.08.16
Beiträge: 9
Fähigkeiten: WBB Lite 1 Anfänger
Herkunft: Letschin

Antworten Zitieren Editieren Melden       UP

Hmm... Besteht leider weiterhin das Problem, trotz der Änderung.

Das Umlaute-Problem hab ich mit dem htmlspecialchars_hotfix behoben, es ist wirklich nur, dass der Thementitel beim Vorschau anzeigen lassen verschwindet, egal ob Umlaute drin sind oder nicht. Und nein, den hotfix hab ich selbstverständlich nicht bei der Änderung benutzt.

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Yelanha: 02.02.17 14:07.

02.02.17 14:04 Yelanha ist offline E-Mail Finden Als Freund hinzufügen
Seiten (8): « vorherige 1 2 3 4 5 6 7 [8] Baumstruktur | Brettstruktur
Gehe zu:

Neues Thema erstellen Antwort erstellen

yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB Lite 1.0.x » [WBB Lite 1.0.x] Hacks und Addons » Themenbeschreibung