YourWBB


yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB Lite 1.0.x » [WBB Lite 1.0.x] Allg. Fragen und Probleme » Probleme mit php 7.0 und höher. » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag 840 Views | | Thema zu Favoriten hinzufügen

Neues Thema erstellen Antwort erstellen

Dieses Thema wurde als unerledigt markiert. Thread unerledigt

Zum Ende der Seite springen Probleme mit php 7.0 und höher.
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Lupin
Mitglied


Dabei seit: 27.01.17
Beiträge: 1

 Probleme mit php 7.0 und höher. Antworten Zitieren Editieren Melden       UP

Hallo Leute,

ich habe sein einigen Jahren ein wbb 1.0.2 am laufen. Dieses wollte ich nun updaten mit dem folgenden Update: Woltlab Burning Board Lite 1.0.x PHP 5.3+ Patch

Dann habe ich auf php 7.0 umgestellt und bekomme die folgende Meldung:
Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /www/htdocs/...../global.php:24 Stack trace: #0 /www/htdocs/w0098234/index.php(4): require() #1 {main} thrown in /www/htdocs/......./global.php on line 24


Gibt es hier eine Lösung für das Problem?

Dieser Beitrag wurde 2 mal editiert, zum letzten Mal von Lupin: 27.01.17 13:57.

27.01.17 13:54 Lupin ist offline E-Mail Finden Als Freund hinzufügen
Viktor Viktor ist männlich
Mitglied


images/avatars/avatar-462.gif

Dabei seit: 17.01.04
Beiträge: 98
Fähigkeiten: WBB2 Profi; WBB Lite 1 Profi
Forenversion: 3.0; 2.3

 RE: Probleme mit php 7.0 und höher. Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Lupin
Hallo Leute,

ich habe sein einigen Jahren ein wbb 1.0.2 am laufen. Dieses wollte ich nun updaten mit dem folgenden Update: Woltlab Burning Board Lite 1.0.x PHP 5.3+ Patch

Dann habe ich auf php 7.0 umgestellt und bekomme die folgende Meldung:
Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /www/htdocs/...../global.php:24 Stack trace: #0 /www/htdocs/w0098234/index.php(4): require() #1 {main} thrown in /www/htdocs/......./global.php on line 24


Gibt es hier eine Lösung für das Problem?


Hallo,

das gibt es nicht mehr unter PHP7.

In der Datei "global.php" suche:

code:
1:
2:
3:
@set_magic_quotes_runtime(0);


Ersetze mit:
code:
1:
2:
3:
4:
5:
6:
if(version_compare(PHP_VERSION, '5.3.0', '<'))
{
@set_magic_quotes_runtime(0);
}


Das gleiche musst du auch in der Datei "acp/global.php" machen.

Gruß
Viktor großes Grinsen

__________________
Mein Supportboard

27.01.17 20:36 Viktor ist offline E-Mail WWW Finden Als Freund hinzufügen
Lila Raven Lila Raven ist weiblich
Mitglied


Dabei seit: 14.06.12
Beiträge: 33
Fähigkeiten: WBB Lite 1 Anfänger
Herkunft: Berlin
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Hi Ich habs auch mal gemacht und siehe da es ging wieder ^^

Nun hab Ich aber das Problem wenn ich einen Beitrag anschaue das oben folgende Meldung steht:

code:
1:
2:
3:
4:
5:
6:
7:
8:
9:
10:
11:
12:
13:
14:
15:
Warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /www/htdocs/wxxxxxxx/Adresse/acp/lib/class_parse.php on line 167

Warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /www/htdocs/wxxxxxxx/Adresse/acp/lib/class_parse.php on line 177

Warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /www/htdocs/wxxxxxxx/Adresse/acp/lib/class_parse.php on line 187

Warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /www/htdocs/wxxxxxxx/Adresse/acp/lib/class_parse.php on line 167

Warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /www/htdocs/wxxxxxxx/Adresse/acp/lib/class_parse.php on line 177

Warning: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead in /www/htdocs/wxxxxxxx/Adresse/acp/lib/class_parse.php on line 187

Warning: Cannot modify header information - headers already sent by (output started at /www/htdocs/wxxxxxxx/Adresse/acp/lib/class_parse.php:167) in /www/htdocs/wxxxxxxx/Adresse/acp/lib/functions.php on line 97


Und ich keine Lösung parat habe :/ kann mir vllt. einer von euch weiter helfen???

Herzliche Grüße Lila
10.04.17 12:47 Lila Raven ist offline E-Mail WWW Finden Als Freund hinzufügen
S!equenz
Last Man Standing


Dabei seit: 10.07.12
Beiträge: 603
Fähigkeiten: WBB2 Fortgeschritten
Forenversion: 2.3

Antworten Zitieren Editieren Melden       UP

https://www.v-gn.de/wbb/thread.php?threadid=16059

Ich Update hier auf your-wbb.de demnächst die Updates.

__________________
Lüge Zweckmäßige Übertreibung
10.04.17 22:06 S!equenz ist offline E-Mail Finden Als Freund hinzufügen
Baumstruktur | Brettstruktur
Gehe zu:

Neues Thema erstellen Antwort erstellen

yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB Lite 1.0.x » [WBB Lite 1.0.x] Allg. Fragen und Probleme » Probleme mit php 7.0 und höher.