YourWBB


yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB Lite 1.0.x » [WBB Lite 1.0.x] Ideen, Wünsche und Suche » Hide Avatar & Signatur » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag 20.468 Views | | Thema zu Favoriten hinzufügen
Seiten (4): « vorherige 1 2 [3] 4 nächste »
Neues Thema erstellen Antwort erstellen

Dieses Thema wurde als erledigt markiert. Thread erledigt

Zum Ende der Seite springen Hide Avatar & Signatur
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
levi-chan
Mitglied


Dabei seit: 16.11.08
Beiträge: 14

Antworten Zitieren Editieren Melden       UP

danke schon mal für die hilfe. (: wie leite ich denn die thread_postbit auf eine gasttaugliche version um?
28.06.14 17:21 levi-chan ist offline E-Mail Finden Als Freund hinzufügen
Pigsel
Mitglied


images/avatars/avatar-5749.gif

Dabei seit: 05.09.11
Beiträge: 745
Fähigkeiten: WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

hab gerade gesehen auf Seite 1 hatte Jacqy bereits die Frage nach der Gastlösung für das icon beantwortet Augenzwinkern

jedenfalls die thread_postbit, da kommt es auf die genaue eintragung in deiner thread.php an.

bei mir sieht das so aus:

php:
1:
2:
3:
4:
if(($wbbuserdata['issupermod']==1) || $modpermissions['userid'] || $wbbuserdata['groupid']!=5) {
 eval ("\$deletepost = \"".$tpl->get("deletpost")."\";");
 eval ("\$postbit .= \"".$tpl->get("thread_postbit")."\";"); }
 else eval ("\$postbit .= \"".$tpl->get("thread_postbit_gast")."\";");


wenn du den "delpost" nicht drin hast:

php:
1:
2:
3:
if(($wbbuserdata['groupid']!=5) {
 eval ("\$postbit .= \"".$tpl->get("thread_postbit")."\";"); }
 else eval ("\$postbit .= \"".$tpl->get("thread_postbit_gast")."\";");


da kann man dann ganz nach belieben alles rauswerfen bis zu einem Leeren Template wenn einen die Gäste mal geärgert haben Augenzwinkern

thread_postbit_gast ist eine kopie vom thread_postbit nur eben auf die Dinge abgespeckt die Gäste sehen dürfen

__________________
Ein Leben ohne CodeBug's ist ein Leben im Paradies

28.06.14 21:06 Pigsel ist offline E-Mail Finden Als Freund hinzufügen
levi-chan
Mitglied


Dabei seit: 16.11.08
Beiträge: 14

Antworten Zitieren Editieren Melden       UP

vielen dank, hat super funktioniert! (:
29.06.14 19:58 levi-chan ist offline E-Mail Finden Als Freund hinzufügen
Pigsel
Mitglied


images/avatars/avatar-5749.gif

Dabei seit: 05.09.11
Beiträge: 745
Fähigkeiten: WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von levi-chan
vielen dank, hat super funktioniert! (:


klasse, der Vorteil mit dem wbbuserdata[groupid] kann man erweitern wenn man zB. für Bewerber oder Newbies oder wie man sie auch nennen mag, auch die Grafiken zu verstecken wünscht das ginge dann so:

Zitat:
if(($wbbuserdata['groupid']!=5 || $wbbuserdata['groupid']!=zusätzliche groupid) {
eval ("\$postbit .= \"".$tpl->get("thread_postbit")."\";"); }
else eval ("\$postbit .= \"".$tpl->get("thread_postbit_gast")."\";");


usw.

__________________
Ein Leben ohne CodeBug's ist ein Leben im Paradies

Dieser Beitrag wurde 2 mal editiert, zum letzten Mal von Pigsel: 29.06.14 21:42.

29.06.14 21:41 Pigsel ist offline E-Mail Finden Als Freund hinzufügen
White_Mustang
Mitglied


images/avatars/avatar-5761.gif

Dabei seit: 20.11.11
Beiträge: 16
Fähigkeiten: WBB2 Anfänger; WBB Lite 1 Fortgeschritten
Forenversion: 2.3; Lite 1.0

Antworten Zitieren Editieren Melden       UP

Ich hab die Lösung für den "UserOnline Hover-Ava"-Hack. Zumindest klappts so bei mir :'D
Gäste kriegen das jetzt einfach nicht mehr angezeigt.. also keinen NoAva, sondern einfach gar nichts, wohingegen User die Avatare regulär sehen sollten xD


suche in der index.php
code:
1:
if($avaqry['avatarid'] && $showavatar==1 && $wbbuserdata['showavatars']==1)
ersetze durch:
code:
1:
if($avaqry['avatarid'] && $showavatar==1 && $wbbuserdata['showavatars']==1 && $wbbuserdata['userid']>0)

Dieser Beitrag wurde 3 mal editiert, zum letzten Mal von White_Mustang: 04.09.14 17:33.

04.09.14 17:27 White_Mustang ist offline E-Mail WWW Finden Als Freund hinzufügen
Lakota-Chan
Mitglied


Dabei seit: 11.10.09
Beiträge: 13
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

ich weiß nicht, ob dieser Punkt inzwischen geklärt werden konnte:
Zitat:
Original von Jaluesa
Mich würde es auch interessieren, die Signatur im Profil für Gäste auszublenden. Habe es schon selbst versucht, aber irgendwie will es nicht passen :/

Der Code den ich benutze ist dieser hier:
code:
1:
2:
$signatur=$parse->doparse($user_info['signature'],$allowsigsmilies,$allowsightml,$allowsigbbcode,$maxsigimage);
if ($user_info['signature']=="") $signatur="<p align=\"center\">Es wurde keine Signatur eingetragen.";


Und wenn ich es den Teil zum ausblenden der Usergruppe 0 hinter das $user_info['signature'] packe, erscheint bei Gästen zwar nichts, aber bei Usern, etc. steht anstatt dem Bild eine 1

wenn nicht... so habe ich es gelöst ohne eine zusätzliche .tpl zu erstellen

suche in der profile.php:
code:
1:
if ($user_info['signature']=="") $signatur="<p align=\"center\">Es wurde keine Signatur eingetragen.";

ersetze mit:
code:
1:
if ($user_info['signature']=="" OR $wbbuserdata['userid']=='0' ) $signatur="<p align=\"center\">Es wurde keine Signatur eingetragen.";
20.09.14 21:43 Lakota-Chan ist offline E-Mail Finden Als Freund hinzufügen
Shalimar Shalimar ist weiblich
Mitglied


Dabei seit: 22.07.13
Beiträge: 23
Fähigkeiten: WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von whitepanther
Hallo,

erst einmal danke für diese Codeschnipsel. Der "Hack" funktioniert insofern, dass die Avatare nicht mehr angezeigt werden, allerdings erscheint stattdessen nicht der Noavatar obwohl der Hack eingebaut ist. Der Bereich unter den Namen bleibt einfach leer. Keine Fehlermeldungen oder so. Nichts. Hat jemand eine Idee woran das liegen könnte?

LG


Liegt hierfür inzwischen eine Lösung vor?
16.11.14 18:26 Shalimar ist offline Finden Als Freund hinzufügen
Inkblot
Mitglied


Dabei seit: 24.05.14
Beiträge: 13
Fähigkeiten: WBB2 Fortgeschritten; WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Das würde mich ehrlich gesagt auch interessieren, weil ich genau das gleiche Problem habe.
Das Ava wird nicht mehr angezeigt, aber er zeigt auch nicht das noavatar.gif, obwohl der Hack drin ist.
24.11.14 10:55 Inkblot ist offline E-Mail Finden Als Freund hinzufügen
Pigsel
Mitglied


images/avatars/avatar-5749.gif

Dabei seit: 05.09.11
Beiträge: 745
Fähigkeiten: WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Inkblot
Das würde mich ehrlich gesagt auch interessieren, weil ich genau das gleiche Problem habe.
Das Ava wird nicht mehr angezeigt, aber er zeigt auch nicht das noavatar.gif, obwohl der Hack drin ist.


siehe hier: noava

dann kann man auch auf deiner Seite das Problem austreiben, die Lösung steht zwar bereits geschrieben, aber die meisten User haben es gern kompliziert, mit einem Hack der einmal quer durch das Forum geht, statt der einfachen Umleitung auf ein angepasstes Template, müsste man sich das Problem individuell ansehen und ebenso individuell lösen

- angehängte PHP thread / profile /index je nach Stelle der fehlenden Ausgabe
- entsprechend dazu die Templates thread_postbit / profile / index / header und evtl. zusätzliche die mit Avatar ausgegeben werden sollen oder zu dem AvatarProblem gehören

- den Seitenlink, das man sich das Problem auch direkt ansehen kann und evtl. kurz und knackig die Lösung des Problems findet

__________________
Ein Leben ohne CodeBug's ist ein Leben im Paradies

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Pigsel: 24.11.14 20:46.

24.11.14 20:45 Pigsel ist offline E-Mail Finden Als Freund hinzufügen
Mr.Gold
Mitglied


Dabei seit: 08.12.15
Beiträge: 8
Fähigkeiten: WBB Lite 2 Anfänger; WBB Lite 1 Fortgeschritten
Herkunft: NRW
Forenversion: Lite 2.0; Lite 1.0

Antworten Zitieren Editieren Melden       UP

Guten Morgen zusammen,

habe nun erfolgreich Avatare, Signaturen und Icons sowie den Hover-Avatar für Gäste ausgeblendet.

Nun habe ich aber mal noch die Frage..
Wie mache ich das auf der Teamseite?

Auch in der Team.tpl und Team.php?

LG Mo
11.12.15 08:36 Mr.Gold ist offline E-Mail Finden Als Freund hinzufügen
Pigsel
Mitglied


images/avatars/avatar-5749.gif

Dabei seit: 05.09.11
Beiträge: 745
Fähigkeiten: WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Mr.Gold
Guten Morgen zusammen,

habe nun erfolgreich Avatare, Signaturen und Icons sowie den Hover-Avatar für Gäste ausgeblendet.

Nun habe ich aber mal noch die Frage..
Wie mache ich das auf der Teamseite?

Auch in der Team.tpl und Team.php?

LG Mo

soll die Teamseite für Gäste (komplett) gesperrt sein

team.php suche

code:
1:
2:
3:
4:
<?php
$filename="team.php";

require("./global.php");


füge darunter ein

code:
1:
if($wbbuserdata['userid']==0) access_error();


sollen aber nur die Avatare von der Team.php gesperrt werden müsst ich wissen was du für eine Teamseite hast, es gibt ja nach meinem Kenntnisstand mind. 3 Versionen

standard-Ausgabe, die "Erweiterte Teamseitenbearbeitung im ACP" und dann noch die Teamgruppenversion

in der team.php den output umlenken auf team_gast.tpl

code:
1:
2:
3:
4:
5:
6:
if($wbbuserdata[userid]) {
eval("\$tpl->output(\"".$tpl->get("team")."\");");
}
else {
eval("\$tpl->output(\"".$tpl->get("team_gast")."\");");
}


das team.tpl kopieren und die Kopie umbennen in team_gast.tpl

dann im team_gast.tpl die Änderung vornehmen, alles was zum Avatar gehört entfernen, speichern hochladen, testen und ggf. nochmal für die Optik nachbessern

das Umlenken funktioniert auch für die "Erweiterte Teamseitenbearbeitung im ACP"

Aber bei der Version kann man im ACP entscheiden ob und wenn ja welche Avatare verwendet werden, man kann da also beides machen, entweder umlenken auf team_gast oder neutrale Bilder im ACP eintragen die dann auf der Teamseite ausgegeben werden oder auch Beides für evtl. weitere Änderungen

Edit: die Umleitung kann man auch für die Mitgliederliste machen falls man da Avatare ausgeben lässt

das gleiche gilt für den header den kann man auch gruppenabhängig machen bei der Umleitung, man muss es eben nur wollen *g dann kann man fragen und dann kriegt man auch die Lösung

__________________
Ein Leben ohne CodeBug's ist ein Leben im Paradies

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Pigsel: 11.12.15 15:00.

11.12.15 14:55 Pigsel ist offline E-Mail Finden Als Freund hinzufügen
Mr.Gold
Mitglied


Dabei seit: 08.12.15
Beiträge: 8
Fähigkeiten: WBB Lite 2 Anfänger; WBB Lite 1 Fortgeschritten
Herkunft: NRW
Forenversion: Lite 2.0; Lite 1.0

Antworten Zitieren Editieren Melden       UP

Hey großes Grinsen

Vielen Dank für die schnelle Antwort wieder Freude

Gleich 3 Versionen Irre
Nun, da die Hacks schon sehr lange in der Version schlummern, kann ich das gar nicht mehr so genau sagen.
Aber ich hänge, bevor ich da auf gut Glück was versuche, lieber mal die Team.php hier an und hoffe das hilft dann etwas weiter..

Ich möchte eigentlich nur die Avatare die : Hier auftauchen dann, für Gäste als Noavatar anzeigen lassen, mehr nicht. So wie eben in der Memberliste.

Dateianhang:
txt Team php.txt (6,38 KB, 3 mal heruntergeladen)
11.12.15 21:19 Mr.Gold ist offline E-Mail Finden Als Freund hinzufügen
Pigsel
Mitglied


images/avatars/avatar-5749.gif

Dabei seit: 05.09.11
Beiträge: 745
Fähigkeiten: WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

das ist doch einfach gewesen, ich gehe davon aus das du das Template vom "noavatar-Hack" bei dir auf dem Server hast?

falls nicht, hab ich entsprechend deinen Vorgaben eins erstellt und mit in den Anhang getan

ich habe die desweiteren falls du es unterscheiden magst zwischen gästen und noavatar für deine User ohne Avatar eine Version für Gastavatare (avatar_image_gast) mit in den Anhang gepackt

kannst du dir alles anpassen wie es dir beliebt, die ".gif" lassen oder die Endungen ändern, das die zu den Grafiken passen, etc. was immer du magst

P.S. da müsste man mal mit den Betereibern meckern, das keine rar-Dateien möglich sind, da lässt sich einstellen das keine Veränderungen an den Archiven möglich sind .. wenn ich etwas hochlade soll das schließlich auch so bleiben und auch beim Hilfesuchenden so ankommen wie es hochgeladen ist Belehr

Dateianhang:
zip teamseiten-mrgold.zip (5,44 KB, 2 mal heruntergeladen)


__________________
Ein Leben ohne CodeBug's ist ein Leben im Paradies

11.12.15 23:12 Pigsel ist offline E-Mail Finden Als Freund hinzufügen
Mr.Gold
Mitglied


Dabei seit: 08.12.15
Beiträge: 8
Fähigkeiten: WBB Lite 2 Anfänger; WBB Lite 1 Fortgeschritten
Herkunft: NRW
Forenversion: Lite 2.0; Lite 1.0

Antworten Zitieren Editieren Melden       UP

Guten Morgen smile

Ich glaube ich habe was vergessen Augen rollen
Habe deine Dateien entzippt und eingebaut über FTP aber irgendwie wird immer noch das Ava angezeigt auf der Team, wenn ich mich abmelde und als Gast schaue Peinlich
Floeten
Entweder bin noch nicht ganz wach oder hab wieder mal was übersehen?
tut mir Leid... Aufgeben
12.12.15 08:56 Mr.Gold ist offline E-Mail Finden Als Freund hinzufügen
Pigsel
Mitglied


images/avatars/avatar-5749.gif

Dabei seit: 05.09.11
Beiträge: 745
Fähigkeiten: WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Mr.Gold
Guten Morgen smile

Ich glaube ich habe was vergessen Augen rollen
Habe deine Dateien entzippt und eingebaut über FTP aber irgendwie wird immer noch das Ava angezeigt auf der Team, wenn ich mich abmelde und als Gast schaue Peinlich
Floeten
Entweder bin noch nicht ganz wach oder hab wieder mal was übersehen?
tut mir Leid... Aufgeben


muss dir nicht leid tun muss mir eigentlich .

also momentan sieht man auf der teamseite gar nichts

ich hab ja noch die aus dem Archiv bei mir, ich hab da mal eine } entfernt

das müsste jetzt funktionieren, sofern du natürlich die Grafiken erstellt hast, das habe ich ja in dem Archiv nicht mit drin gehabt und habe ich wieder nicht dabei.

die dateien die in den templates aufgerufen werden müssten schon so wie sie im template eingetragen sind hochgeladen sein und den gleichen namen haben wie im template

wierum du das machst ob du das template an deine Ablage anpast und die Darteinamen an deine Grafiken oder umgekehrt, ist egal aber er muss was zum anzeigen haben Augenzwinkern

wenn du "Style"abhängig arbeitest, bei den Grafiken ist das auch egal. weil in den Templates direkt images steht undn icht {imagefolder}/ sodass du nur 1 mal die Grafiken brauchen würdest, für Styleabhängig zB. verschiedenfarbig je nach style müsstest du in jedem Styleordner dann ein gastavatar und ein noavatar haben

ich habe momentan keine TestSeite wo ich das durchtesten kann woran es liegt, aber der Teamseitenfehler mit dem unexpected } in line 141 ist behoben

Dateianhang:
zip teamseiten-mrgold-1.zip (3,35 KB, 1 mal heruntergeladen)


__________________
Ein Leben ohne CodeBug's ist ein Leben im Paradies

12.12.15 13:37 Pigsel ist offline E-Mail Finden Als Freund hinzufügen
Mr.Gold
Mitglied


Dabei seit: 08.12.15
Beiträge: 8
Fähigkeiten: WBB Lite 2 Anfänger; WBB Lite 1 Fortgeschritten
Herkunft: NRW
Forenversion: Lite 2.0; Lite 1.0

Antworten Zitieren Editieren Melden       UP

Nachdenken was ein Werk Irre fröhlich

Also jetzt muss ich mal genauer fragen...

Ich habe geschaut und den noavatar-Hack drinn.
In der Mitgliederliste und in den Profilen musste ich, damit das noavatar angezeigt wird, je eine .php und eine .tpl bearbeiten.
Das hat ja auch geklappt.

Die Dateien, die ich von dir runtergeladen habe, muss ich die noch umbenennen? verwirrt
Wenn ich den Ordner normal öffne, dann steht da:

- Team-noavatar-tpl

Über Ftp sehe ich aber das da steht:

- Team-noavatar-tpl.php

Sind das nun tpl's oder Versagt php's ?

Ich hatte das am Anfang mit den 5 Dateien von dir so gemacht, dass ich die von dir benannte:
Team - Kopie umbenannt habe in team.php und meine originale mit dieser ersetzt habe.
Die Dateien Team-gastavatar-tpl.php und Team-noavatar-tpl.php habe ich bei die anderen php Dateien in den Hauptordner geladen.
Und die Dateien avatar_image_gast.tpl und noavatar_image.tpl zu den anderen tpl Dateien in den Ordner templates.

Das wars..
Jetzt habe ich nochmal die beiden neuen phps rübergezogen und die anderen beiden ersten überschrieben.
Die Fehlermeldung ist weg, die gifs und pngs sind erstellt und in allen styleordnern, aber geändert hat sich glaube ich nicht viel, oder?
Watt?

LG Mo
12.12.15 16:43 Mr.Gold ist offline E-Mail Finden Als Freund hinzufügen
Pigsel
Mitglied


images/avatars/avatar-5749.gif

Dabei seit: 05.09.11
Beiträge: 745
Fähigkeiten: WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Mr.Gold
Nachdenken was ein Werk Irre fröhlich

Also jetzt muss ich mal genauer fragen...

Ich habe geschaut und den noavatar-Hack drinn.
In der Mitgliederliste und in den Profilen musste ich, damit das noavatar angezeigt wird, je eine .php und eine .tpl bearbeiten.
Das hat ja auch geklappt.

Die Dateien, die ich von dir runtergeladen habe, muss ich die noch umbenennen? verwirrt
Wenn ich den Ordner normal öffne, dann steht da:

- Team-noavatar-tpl

Über Ftp sehe ich aber das da steht:

- Team-noavatar-tpl.php

Sind das nun tpl's oder Versagt php's ?

Ich hatte das am Anfang mit den 5 Dateien von dir so gemacht, dass ich die von dir benannte:
Team - Kopie umbenannt habe in team.php und meine originale mit dieser ersetzt habe.
Die Dateien Team-gastavatar-tpl.php und Team-noavatar-tpl.php habe ich bei die anderen php Dateien in den Hauptordner geladen.
Und die Dateien avatar_image_gast.tpl und noavatar_image.tpl zu den anderen tpl Dateien in den Ordner templates.

Das wars..
Jetzt habe ich nochmal die beiden neuen phps rübergezogen und die anderen beiden ersten überschrieben.
Die Fehlermeldung ist weg, die gifs und pngs sind erstellt und in allen styleordnern, aber geändert hat sich glaube ich nicht viel, oder?
Watt?

LG Mo


sorry wegen dem Chaos, also die team.php ist die team.php

einmal mit dem -noavatar.tpl-verknüpft und einmal mit dem -gastavatar.tpl verknüpft

das heißt umbenennen, dann wenn in team.php dann kannst du ENTWEDER mit dem noavatar.tpl arbeiten ODER dem gastavatar,.tpl so wie sie bezeichnet waren

avatar_image_gast.tpl + Team-gastavatar-tpl.php unbenennen in team.php (wenn du die Unterscheidung zwischen Gast-Avatar und User-noavatar haben möchtest

noavatar_image.tpl + Team-noavatar-tpl.php umbenennen in team.php (wenn du keine Unterscheidung haben magst)

wenn du das kombiniert haben magst kann man das nochmal anpassen, aber die beiden Alternativen hatte ich bisher

es ist die gleiche team.php ich habe nur angetragen welches tpl verknüpft ist unglücklich sorry für die Umstände

hast du die Endungen für die grafiken in den templates angepasst? das es nicht eine png ist obwohl im template gif steht Augenzwinkern

ansonsten müsste man denke ich sehen können

__________________
Ein Leben ohne CodeBug's ist ein Leben im Paradies

12.12.15 20:08 Pigsel ist offline E-Mail Finden Als Freund hinzufügen
Mr.Gold
Mitglied


Dabei seit: 08.12.15
Beiträge: 8
Fähigkeiten: WBB Lite 2 Anfänger; WBB Lite 1 Fortgeschritten
Herkunft: NRW
Forenversion: Lite 2.0; Lite 1.0

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Pigsel

noavatar_image.tpl + Team-noavatar-tpl.php umbenennen in team.php (wenn du keine Unterscheidung haben magst)

wenn du das kombiniert haben magst kann man das nochmal anpassen, aber die beiden Alternativen hatte ich bisher

es ist die gleiche team.php ich habe nur angetragen welches tpl verknüpft ist unglücklich sorry für die Umstände

hast du die Endungen für die grafiken in den templates angepasst? das es nicht eine png ist obwohl im template gif steht Augenzwinkern

ansonsten müsste man denke ich sehen können


Guten Morgen großes Grinsen

Irgendwann wird es schon, sofern deine Geduld es noch mitmacht. fröhlich

Ich habe nun oben beschriebenes gemacht da ich keinen Unterschied benötige:
noavatar_image.tpl war ja schon im Ordner templates.
Team-noavatar-tpl.php habe ich umbenannt in team.php.

alles was ich nicht brauchte hab ich rausgenommen.

Ich habe dann nochmal geschaut ob auch in allen Image ordner ein noavatar.gif drin ist, da es ja so im tpl steht.
Sind drinnen... Freude

Team Anzeige: unverändert mit Avas... großes Grinsen

Nun fiele mir nur noch ein, das es am Verweis auf den Image Ordner liegen könnte?
Wenn nicht an den Tabellen..
Meine FTP Ordner sind so angelegt:

- acp
- images
- images_carol
- images_christmascarol
- Images_cream
- mysqldumper
- templates
...
und darunter dann die php Dateien aufgelistet.
13.12.15 10:08 Mr.Gold ist offline E-Mail Finden Als Freund hinzufügen
Pigsel
Mitglied


images/avatars/avatar-5749.gif

Dabei seit: 05.09.11
Beiträge: 745
Fähigkeiten: WBB Lite 1 Fortgeschritten
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

zum Punkt Geduld - hab ich unerschöpflich Augenzwinkern

was hast du noch raus genommen und wo genau raus genommen?

BTT Neuer Versuch - hast du deine originale team.php noch?
ich habe gedacht, wenn dem das mit dem noavatar.tpl nicht gefällt, stellen wir ihn gleich auf _gast um, direkt an den Stellen wo die Ausgaben geregelt werden

Der neue Plan sieht vor, das die Gäste geänderte Templates zu sehen kriegen, wo direkt der Pfad zur Grafik drin ist

Wenn die Gäste ein festes Template kriegen wo der Pfad direkt drin steht sollte offiziell das Problem von Tisch sein

suche in deiner originalen team.php
code:
1:
eval("\$adminbits .= \"".$tpl->get("team_adminbit")."\";");

ersetze mit
code:
1:
2:
if($wbbuserdata['userid']==0) {eval("\$adminbits .= \"".$tpl->get("team_adminbit_gast")."\";");}
  eval("\$adminbits .= \"".$tpl->get("team_adminbit")."\";");

suche
code:
1:
eval("\$supermodbits .= \"".$tpl->get("team_adminbit")."\";");

ersetze mit
code:
1:
2:
if($wbbuserdata['userid']==0) {eval("\$adminbits .= \"".$tpl->get("team_adminbit_gast")."\";");}
  eval("\$supermodbits .= \"".$tpl->get("team_adminbit")."\";");

suche
code:
1:
eval("\$moderatorbits .= \"".$tpl->get("team_modbit")."\";");

ersetze mit
code:
1:
2:
if($wbbuserdata['userid']==0) {eval("\$moderatorbits .= \"".$tpl->get("team_modbit_gast")."\";");} 
 eval("\$moderatorbits .= \"".$tpl->get("team_modbit")."\";");

erstelle kopien von den beiden Templates
team_adminbit / team_modbit

Trage an der Stelle wo die Avatare ausgegeben werden sollen folgendes ein
code:
1:
<img src="images/noavatar.png" border="0">

speichern, hochladen, testen
wenn sich die Seite dann immernoch weigert muss ich mir die Templates zu deiner originalen team.php ansehen

P.S. wen das noavatar.png für jeden Style anders sein soll nimst du {imagefolder}/ anstelle von images/
Dann sucht die Ausgabe in den im Designpack angegebenen "Ordner für Bilder" nach der entsprechenden Grafik noavatar.png

edit: Platz sparen

__________________
Ein Leben ohne CodeBug's ist ein Leben im Paradies

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Pigsel: 13.12.15 15:54.

13.12.15 15:53 Pigsel ist offline E-Mail Finden Als Freund hinzufügen
Mr.Gold
Mitglied


Dabei seit: 08.12.15
Beiträge: 8
Fähigkeiten: WBB Lite 2 Anfänger; WBB Lite 1 Fortgeschritten
Herkunft: NRW
Forenversion: Lite 2.0; Lite 1.0

Antworten Zitieren Editieren Melden       UP

Hallöchen smile

Ich habe zuerst deine Angaben hier probiert und dann den Team.php Inhalt wie in PN angegeben geändert.

Das Ergebnis ist in beiden Versuchen das Gleiche großes Grinsen

http://www.storybook-tales.de/team.php

Übrigens auch als angemeldeter User sieht man .. nichts mehr fröhlich

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Mr.Gold: 15.12.15 12:10.

15.12.15 12:08 Mr.Gold ist offline E-Mail Finden Als Freund hinzufügen
Seiten (4): « vorherige 1 2 [3] 4 nächste » Baumstruktur | Brettstruktur
Gehe zu:

Neues Thema erstellen Antwort erstellen

yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB Lite 1.0.x » [WBB Lite 1.0.x] Ideen, Wünsche und Suche » Hide Avatar & Signatur