YourWBB


yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB Lite 1.0.x » [WBB Lite 1.0.x] Allg. Fragen und Probleme » Umlaute teilweise da und teilweise nicht » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag 423 Views | | Thema zu Favoriten hinzufügen

Neues Thema erstellen Antwort erstellen

Dieses Thema wurde als unerledigt markiert. Thread unerledigt

Zum Ende der Seite springen Umlaute teilweise da und teilweise nicht
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
FrauSchneider
Mitglied


Dabei seit: 23.10.18
Beiträge: 11
Forenversion: Lite 1.0

 Umlaute teilweise da und teilweise nicht Antworten Zitieren Editieren Melden       UP

Problembeschreibung:

Einige Umlaute werden nicht richtig angezeigt. Andere wiederrum schon. Habe schon alles ausprobiert.



Fehlermeldung:
gibt es nicht


Link zum Forum und Screenshot (KEINE Bilderhoster, per Dateianhang):

https://www.plaudertreff.com/




Was wurde zuletzt geändert oder eingebaut?

noch nichts

Dateianhang:
jpg beispiel.jpg (22 KB, 152 mal heruntergeladen)
23.10.18 14:13 FrauSchneider ist offline E-Mail Finden Als Freund hinzufügen
S!equenz
Last Man Standing


Dabei seit: 10.07.12
Beiträge: 722
Fähigkeiten: WBB2 Fortgeschritten
Forenversion: 2.3

Antworten Zitieren Editieren Melden       UP

Ich vermute das ist kein Standard WBB sondern du verwendest eine neuere PHP Version als 5.3 und hast somit schon diverse änderungen durchgeführt?

Welche PHP Version?
Welche Änderungen wurden durchgeführt?

Edit:

Erstell mal eine php.ini im Forenroot mit folgendem Inhalt:
code:
1:
default_charset = "ISO-8859-1"


Du kannst das auch direkt in die php.ini reinschreiben wenn du zugriff hast.

Wenn beides nicht geht kannst du in global.php und acp/global.php nach <?php mal folgendes probieren:

code:
1:
ini_set('default_charset', "ISO-8859-1");


__________________
Lüge Zweckmäßige Übertreibung
23.10.18 18:42 S!equenz ist offline E-Mail Finden Als Freund hinzufügen
FrauSchneider
Mitglied


Dabei seit: 23.10.18
Beiträge: 11
Forenversion: Lite 1.0

Themenstarter Thema begonnen von FrauSchneider
Antworten Zitieren Editieren Melden       UP

Bereits alles probiert. Aber wieder rückgängig gemacht. Deswegen schrieb ich schon alles probiert.

Php 5.3 ist es.
23.10.18 21:41 FrauSchneider ist offline E-Mail Finden Als Freund hinzufügen
S!equenz
Last Man Standing


Dabei seit: 10.07.12
Beiträge: 722
Fähigkeiten: WBB2 Fortgeschritten
Forenversion: 2.3

Antworten Zitieren Editieren Melden       UP

Setz mal den default charset von Apache auf ISO-8859-1.

Denn die Umlaute die bei dir probleme verursachen sind in den Templates nicht in der Datenbank und da du php 5.3 hast sollte das eh keine Probleme machen.

Ja ich vermute es kann nur Apache sein oder was du halt als Webserver verwendest.

Apache httpd.conf
code:
1:
AddDefaultCharset ISO-8859-1


__________________
Lüge Zweckmäßige Übertreibung
23.10.18 23:06 S!equenz ist offline E-Mail Finden Als Freund hinzufügen
FrauSchneider
Mitglied


Dabei seit: 23.10.18
Beiträge: 11
Forenversion: Lite 1.0

Themenstarter Thema begonnen von FrauSchneider
Antworten Zitieren Editieren Melden       UP

Haue ich den Code dann in eine php.ini oder verstehe ich dich jetzt falsch?

Ich hab mir jetzt mal die Templates genauer angesehen. Da sind die Umlaute tatsächlich falscg

Hier ein beispiel:

Aus einem der folgenden Gr&uuml;nde fehlt Ihnen die Berechtigung, diese Seite zu betreten:


Ich werde irre.

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von FrauSchneider: 24.10.18 07:31.

24.10.18 07:30 FrauSchneider ist offline E-Mail Finden Als Freund hinzufügen
jacqy jacqy ist weiblich
Alternativ Mitglied


images/avatars/avatar-5823.jpg

Dabei seit: 01.08.05
Beiträge: 965
Herkunft: Passau(hergezogen)

Antworten Zitieren Editieren Melden       UP

Wenn du Hilfe brauchst, melde dich mal via PN.

Wo bist du denn gehostet? Eventuell hilft auch das. https://www.hackeinbau.de/mediawiki/Umla...t_mehr_sichtbar

__________________
<<<<<<Ist in Arbeit>>>>>>>
Zunge raus
24.10.18 11:33 jacqy ist offline E-Mail Finden Als Freund hinzufügen
S!equenz
Last Man Standing


Dabei seit: 10.07.12
Beiträge: 722
Fähigkeiten: WBB2 Fortgeschritten
Forenversion: 2.3

Antworten Zitieren Editieren Melden       UP

Ne wie ich geschrieben habe in die httpd.conf falls du Apache benutzt, wenn du einen anderen Webserver benutzt muss ein anderer Code in eine andere Datei eingefügt werden.

Jacqy, damit hat das nichts zutun da sie PHP 5.3 einsetzt und außerdem nur die Umlaute in den Templates Probleme machen, nicht die in der Datenbank.

Was du auch noch machen kannst wenn nicht schon gemacht ist nochmal hier auf your-wbb.de oder so das wbblite erneut runterladen und nochmal neu hochladen und installieren, nur zur sicherheit.

Aber ich vermute es ist der Webserver.

Edit:

du kannst einfach eine .htaccess datei erstellen im forenroot mit dem Code.

__________________
Lüge Zweckmäßige Übertreibung
24.10.18 20:26 S!equenz ist offline E-Mail Finden Als Freund hinzufügen
FrauSchneider
Mitglied


Dabei seit: 23.10.18
Beiträge: 11
Forenversion: Lite 1.0

Themenstarter Thema begonnen von FrauSchneider
Antworten Zitieren Editieren Melden       UP

Apache ja. Aber wo änder ich die httpd.conf

ich hab das wbblite von hier und bereits zweimal neu installiert.

htcaccess auch bereits probiert.


danke für eure bemühungen


Hier nochmal ein Beispiel aus der Datenbank

bb1_groups im Strukturbaum

G?ste und nicht Gäste

Dateianhang:
jpg grpups.jpg (26,36 KB, 82 mal heruntergeladen)

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von FrauSchneider: 25.10.18 12:39.

25.10.18 12:26 FrauSchneider ist offline E-Mail Finden Als Freund hinzufügen
jacqy jacqy ist weiblich
Alternativ Mitglied


images/avatars/avatar-5823.jpg

Dabei seit: 01.08.05
Beiträge: 965
Herkunft: Passau(hergezogen)

Antworten Zitieren Editieren Melden       UP

Wie schon geschrieben melde dich mal per PN und ich schaue mal nach.

__________________
<<<<<<Ist in Arbeit>>>>>>>
Zunge raus
25.10.18 14:53 jacqy ist offline E-Mail Finden Als Freund hinzufügen
S!equenz
Last Man Standing


Dabei seit: 10.07.12
Beiträge: 722
Fähigkeiten: WBB2 Fortgeschritten
Forenversion: 2.3

Antworten Zitieren Editieren Melden       UP

Okay wir haben nun denke ich einen Punkt erreicht wo man wirklich vorort nachschauen muss.

Jaqcy hat ja schon geschrieben Sie würde mal schauen du kannst dich ja mal bei ihr melden, sollte sie das Problem nicht finden würde ich auch mal nachschauen wenn du willst.

Solltet ihr das Problem finden dann wäre es nett wenn ihr es hier postet was es war.

__________________
Lüge Zweckmäßige Übertreibung
25.10.18 20:26 S!equenz ist offline E-Mail Finden Als Freund hinzufügen
FrauSchneider
Mitglied


Dabei seit: 23.10.18
Beiträge: 11
Forenversion: Lite 1.0

Themenstarter Thema begonnen von FrauSchneider
Antworten Zitieren Editieren Melden       UP

Zitat:
Original von S!equenz
Okay wir haben nun denke ich einen Punkt erreicht wo man wirklich vorort nachschauen muss.

Jaqcy hat ja schon geschrieben Sie würde mal schauen du kannst dich ja mal bei ihr melden, sollte sie das Problem nicht finden würde ich auch mal nachschauen wenn du willst.

Solltet ihr das Problem finden dann wäre es nett wenn ihr es hier postet was es war.


Gerne. Ich schicke dir die Daten
27.10.18 23:05 FrauSchneider ist offline E-Mail Finden Als Freund hinzufügen
Dragosius Dragosius ist männlich
Mitglied


Dabei seit: 16.01.04
Beiträge: 171

Antworten Zitieren Editieren Melden       UP

Das hat zwar jetzt nur indirekt mit dem Problem zu tun:

Aber PHP 5.3 ist ja grob fahrlässig, installiere doch zumindest die letzte 5er Version PHP 5.6
PHP 5.6 wird übrigens auch nur noch bis Anfang nächsten Jahres offiziell unterstützt.

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Dragosius: 08.11.18 19:59.

08.11.18 19:58 Dragosius ist offline WWW Finden Als Freund hinzufügen
Slugger Slugger ist männlich
Mitglied


Dabei seit: 11.04.05
Beiträge: 437
Fähigkeiten: WBB2 Anfänger; WBB Lite 2 Anfänger; WBB Lite 1 Fortgeschritten
Herkunft: Innercity
Forenversion: 2.3; Lite 2.0

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Dragosius
Das hat zwar jetzt nur indirekt mit dem Problem zu tun:

Aber PHP 5.3 ist ja grob fahrlässig, installiere doch zumindest die letzte 5er Version PHP 5.6
PHP 5.6 wird übrigens auch nur noch bis Anfang nächsten Jahres offiziell unterstützt.


Entschuldige das ich mein Statement hier abgebe.

Gehe gleich auf PHP 7.x alles dazwischen ist Zeitverschwendung!

Hilfe bekommst du hier!

https://www.v-gn.de/wbb/index.php

__________________
Cu,
Slugger



08.11.18 21:31 Slugger ist offline E-Mail Finden Als Freund hinzufügen
Dragosius Dragosius ist männlich
Mitglied


Dabei seit: 16.01.04
Beiträge: 171

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Slugger
Zitat:
Original von Dragosius
Das hat zwar jetzt nur indirekt mit dem Problem zu tun:

Aber PHP 5.3 ist ja grob fahrlässig, installiere doch zumindest die letzte 5er Version PHP 5.6
PHP 5.6 wird übrigens auch nur noch bis Anfang nächsten Jahres offiziell unterstützt.


Entschuldige das ich mein Statement hier abgebe.

Gehe gleich auf PHP 7.x alles dazwischen ist Zeitverschwendung!

Hilfe bekommst du hier!

https://www.v-gn.de/wbb/index.php


Dies habe ich mit meine letzten Satz doch mehr oder weniger angedeutet. smile
PHP 7.0 wird übrigens genauso lang wie PHP 5.6 offiziell unterstützt.
Also musst du korrekterweise schreiben, mindestens PHP 7.1 smile
Gestern, 18:25 Dragosius ist offline WWW Finden Als Freund hinzufügen
Slugger Slugger ist männlich
Mitglied


Dabei seit: 11.04.05
Beiträge: 437
Fähigkeiten: WBB2 Anfänger; WBB Lite 2 Anfänger; WBB Lite 1 Fortgeschritten
Herkunft: Innercity
Forenversion: 2.3; Lite 2.0

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Dragosius
Zitat:
Original von Slugger
Zitat:
Original von Dragosius
Das hat zwar jetzt nur indirekt mit dem Problem zu tun:

Aber PHP 5.3 ist ja grob fahrlässig, installiere doch zumindest die letzte 5er Version PHP 5.6
PHP 5.6 wird übrigens auch nur noch bis Anfang nächsten Jahres offiziell unterstützt.


Entschuldige das ich mein Statement hier abgebe.

Gehe gleich auf PHP 7.x alles dazwischen ist Zeitverschwendung!

Hilfe bekommst du hier!

https://www.v-gn.de/wbb/index.php


Dies habe ich mit meine letzten Satz doch mehr oder weniger angedeutet. smile
PHP 7.0 wird übrigens genauso lang wie PHP 5.6 offiziell unterstützt.
Also musst du korrekterweise schreiben, mindestens PHP 7.1 smile


Stimmt und die Zeit rennt schneller als wir denken.

PHP 7.1 hat auch bereits sein Auslaufdatum smile
Weshalb man ja schon PHP 7.2 schreiben sollte großes Grinsen

__________________
Cu,
Slugger



Gestern, 19:00 Slugger ist offline E-Mail Finden Als Freund hinzufügen
Baumstruktur | Brettstruktur
Gehe zu:

Neues Thema erstellen Antwort erstellen

yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB Lite 1.0.x » [WBB Lite 1.0.x] Allg. Fragen und Probleme » Umlaute teilweise da und teilweise nicht