YourWBB


yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB Lite 1.0.x » [WBB Lite 1.0.x] Hacks und Addons » Themenbeschreibung » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag 35.704 Views | | Thema zu Favoriten hinzufügen
Seiten (8): « vorherige 1 2 [3] 4 5 6 7 8 nächste »
Neues Thema erstellen Antwort erstellen

Zum Ende der Seite springen Themenbeschreibung 3 Bewertungen - Durchschnitt: 7,003 Bewertungen - Durchschnitt: 7,00
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
seekanddestroy
Mitglied


Dabei seit: 02.10.11
Beiträge: 6

Antworten Zitieren Editieren Melden       UP

Am Anfang gings ja, deshalb hab ich die Info erstma zurück gehalten, aber wie dem auch sei, das war wirklich das Problem geschockt

Vielen, vielen Dank großes Grinsen Ich bin daran fast verzweifelt Ehren
10.10.11 13:29 seekanddestroy ist offline E-Mail Finden Als Freund hinzufügen
bluebird*
Mitglied


Dabei seit: 19.03.11
Beiträge: 3

Antworten Zitieren Editieren Melden       UP

Bei mir schmeißt er nachdem man auf Vorschau geklickt hat auch immer die Themenbeschreibung raus :/ Das HTTP_POST_VARS hab ich allerdings schon umgeändert, und es funktioniert dennoch nicht :/
code:
1:
2:
3:
        $topicdescr = $_POST['subjectdescr'];
	$topicdescr = addslashes(htmlspecialchars($topicdescr));
        $db->query("INSERT INTO bb".$n."_threads (threadid,boardid,topic,iconid,starttime,starterid,starter,lastposttime,lastposterid,lastposter,pollid,important,visible,descr,prefix) VALUES (NULL,'$boardid','".addslashes(htmlspecialchars($topic))."','$iconid','$time','$wbbuserdata[userid]','".addslashes($wbbuserdata[username])."','$time','$wbbuserdata[userid]','".addslashes($wbbuserdata[username])."','$poll_id','$important','".ifelse($board['moderatenew']==10 || $board['moderatenew']==11,0,1)."','".$topicdescr."','".trim($_POST['prefix'])."')");
03.01.12 00:05 bluebird* ist offline E-Mail Finden Als Freund hinzufügen
xAsukax
Mitglied


Dabei seit: 07.11.11
Beiträge: 7
Fähigkeiten: WBB Lite 1 Anfänger
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Hallo,

Ich hab nur eine kleine Frage.
Hab die Themenbeschreibung eingebaut, funktioniert auch super. Kann man irgendwie die Zeichenanzahl erhöhen? Also, dass man ein klein wenig mehr in die Beschreibung schreiben kann?

Freue mich über Antwort smile

LG
08.01.12 01:05 xAsukax ist offline E-Mail Finden Als Freund hinzufügen
Anika90
unregistriert
Antworten Zitieren Editieren Melden       UP

ich finde auch, dass es ein super Hack ist. DUmmerweise bekomme ich dise Fehlermeldung, wenn ich ein Thread anklicke:

code:
1:
Parse error: syntax error, unexpected ';' in /users/findthecrack/www/wbblite102pl3-10.Backup/wbblite/board.php on line 204


und hier der Link zum Forum:

zur Fehlermeldung

und eigentlich bin ich mir sicher, dass ich alles so gemacht habe, wie in der Anleitung und die install.php habe ich ebenfalls ausgeführt
18.04.12 20:24
mkkcs mkkcs ist männlich
Mitglied


images/avatars/avatar-5746.gif

Dabei seit: 06.10.04
Beiträge: 2.051
Fähigkeiten: WBB2 Profi; WBB2 Fortgeschritten; WBB Lite 1 Profi
Herkunft: aus Mamas Bauch
Forenversion: 2.3; 2.2

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von Anika90
ich finde auch, dass es ein super Hack ist. DUmmerweise bekomme ich dise Fehlermeldung, wenn ich ein Thread anklicke:

code:
1:
Parse error: syntax error, unexpected ';' in /users/findthecrack/www/wbblite102pl3-10.Backup/wbblite/board.php on line 204


und hier der Link zum Forum:

zur Fehlermeldung

und eigentlich bin ich mir sicher, dass ich alles so gemacht habe, wie in der Anleitung und die install.php habe ich ebenfalls ausgeführt


wahrscheinlich ein Templatefehler!

in der board.php in der Zeile 204 wird ein Template aufgerufen wo evtl. ein ; nicht in dern Code passt, oder der Fehler liegt direkt in der board.php um der Zeile 204!

__________________
LG Martin
-
grafix-board
http://www.wbbcoderforum.de
hat seine Tore wieder geöffnet!
Style-Einbau-Anleitung
WCF-News: mywbb goes to WCF
18.04.12 20:45 mkkcs ist offline E-Mail WWW Finden Als Freund hinzufügen
Anika90
unregistriert
Antworten Zitieren Editieren Melden       UP

okay jetzt habe ich diese Fehlermeldung:

code:
1:
Parse error: syntax error, unexpected '}' in /users/findthecrack/www/wbblite102pl3-10.Backup/wbblite/board.php on line 205


Habe auch versucht in der board.php einer der beiden { } zu löschen, aber dennoch ist die Fehlermeldung die gleiche

Dateianhang:
unknown board.php (11,14 KB, 8 mal heruntergeladen)

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Anika90: 18.04.12 21:15.

18.04.12 20:55
Bräke
Mitglied


Dabei seit: 01.01.04
Beiträge: 8.189

Antworten Zitieren Editieren Melden       UP

Der eingefügte Abschnitt ist fehlerhaft, bitte nochmals einfügen(überschreiben).
18.04.12 21:13 Bräke ist offline Finden Als Freund hinzufügen
Anika90
unregistriert
Antworten Zitieren Editieren Melden       UP

meintest du das, was im code steht? zumindest wird es mir so angezeigt und habe es einfach nochmal eingefügt. Hier auch den Link zum Forum:

zur Fehlermeldung
18.04.12 21:16
#AHBL
Alternativ Mitglied


Dabei seit: 05.02.12
Beiträge: 134

Antworten Zitieren Editieren Melden       UP

Hast du in der Zeile 205 mal die } entfernt und geschaut was dann passiert?
18.04.12 23:17 #AHBL ist offline E-Mail Finden Als Freund hinzufügen
Anika90
unregistriert
Antworten Zitieren Editieren Melden       UP

ich habe diese Klammer } mal entfernt und jetzt bekomme ich folgende Fehlermeldung:

code:
1:
Parse error: syntax error, unexpected T_ELSE in /users/findthecrack/www/wbblite102pl3-10.Backup/wbblite/board.php on line 205
19.04.12 10:55
Bräke
Mitglied


Dabei seit: 01.01.04
Beiträge: 8.189

Antworten Zitieren Editieren Melden       UP

Probiere mal diese. Ansonsten mal deine Aktuelle board.php anhängen.

Bitte auch möglichst alle Infos geben, zB das du diese Änderung gemacht hast, sonst sucht man sich als Helfender ein wenig doof und dusselig woher das kommt.

Dateianhang:
unknown board.php (10,18 KB, 3 mal heruntergeladen)
19.04.12 12:03 Bräke ist offline Finden Als Freund hinzufügen
Anika90
unregistriert
Antworten Zitieren Editieren Melden       UP

Hey Bräke,

Also die board.php klappt schon einmal super, aber schon tritt das nächste Problem auf. Jetzt kann ich zwar die einzelnen Thread wieder öffnen, aber ein neues Thema kann ich nicht erstellen, denn dann komt die folgende Fehlermeldung:

code:
1:
Parse error: syntax error, unexpected T_VARIABLE in /users/findthecrack/www/wbblite102pl3-10.Backup/wbblite/newthread.php on line 95


Das heißt ja, dass im newthread.php in der Zeile 95 was falsch sein muss und habe da mal nachgesehen und es muss irgendetwas am Hack falsch sein. Dabei habe ich es GENAU so verändert, wie beschrieben in der Anleitung.

Dateianhang:
unknown newthread.php (12 KB, 3 mal heruntergeladen)
19.04.12 12:13
Bräke
Mitglied


Dabei seit: 01.01.04
Beiträge: 8.189

Antworten Zitieren Editieren Melden       UP

Zeile:
code:
1:
$topicdescr = addslashes(htmlspecialchars($topicdescr))
da fehlt am Ende ein ;
19.04.12 12:27 Bräke ist offline Finden Als Freund hinzufügen
Anika90
unregistriert
Antworten Zitieren Editieren Melden       UP

Danke Bräke!

Oh man, was so ein fehlendes Zeichen gleich außer Kraft setzen kann^^

Aber jetzt funktioniert alles super! *Daumen heb*


EDIT:
Zwar wurde das hier schon angesprochen und eine Lösung angebene, aber was muss ich tun, wenn ich die Themenbeschreibung kleiner haben möchte? Zwar würde gesagt, dassman in der board.php <small/> eingeben soll, aber wenn ich dies tue, dann bekomme ich erneut eine Fehlrmeldung

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Anika90: 19.04.12 13:30.

19.04.12 12:32
Bräke
Mitglied


Dabei seit: 01.01.04
Beiträge: 8.189

Antworten Zitieren Editieren Melden       UP

Ersetzte das "$descr" mal gegen
code:
1:
<smallfont>$descr</font>
im Template board_threadbit.htm
19.04.12 17:57 Bräke ist offline Finden Als Freund hinzufügen
Anika90
unregistriert
Antworten Zitieren Editieren Melden       UP

super Bräke^^ und wie bekomme ich nun noch die KLammern entfernt? denn dann ist es perfekt^^
19.04.12 18:01
JiShi
Mitglied


Dabei seit: 13.08.08
Beiträge: 132

Antworten Zitieren Editieren Melden       UP

Hey Anika90,

suche in der board.php:

code:
1:
$descr = ' ('.$description.')';


und ersetze es durch:

code:
1:
$descr = ' '.$description;
19.04.12 18:09 JiShi ist offline E-Mail Finden Als Freund hinzufügen
Anika90
unregistriert
Antworten Zitieren Editieren Melden       UP

ah SEHR schön^^

nochmal ein herzliches Dankeschön an Bräke, #AHBL und JiShi

klappt nun einwandfrei
19.04.12 18:17
Levinas
Mitglied


Dabei seit: 14.04.12
Beiträge: 5
Fähigkeiten: WBB Lite 1 Anfänger
Forenversion: Lite 1.0

Antworten Zitieren Editieren Melden       UP

Hallo! Ich habe den Hack mal eingebaut und auch alles so gemacht wie in der Anleitung. Nur bekomme ich jetz einen SQL-DATABASE ERROR.

An was kann das liegen?

Liebe Grüße.
23.04.12 14:04 Levinas ist offline E-Mail Finden Als Freund hinzufügen
#AHBL
Alternativ Mitglied


Dabei seit: 05.02.12
Beiträge: 134

Antworten Zitieren Editieren Melden       UP

Um dir zusagen, was das SQL-DATABASE ERROR ist braucht man schon die ganze Meldung den SQL-DATABASE ERROR kann viel heißen....
23.04.12 15:19 #AHBL ist offline E-Mail Finden Als Freund hinzufügen
Seiten (8): « vorherige 1 2 [3] 4 5 6 7 8 nächste » Baumstruktur | Brettstruktur
Gehe zu:

Neues Thema erstellen Antwort erstellen

yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB Lite 1.0.x » [WBB Lite 1.0.x] Hacks und Addons » Themenbeschreibung