YourWBB


yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB 2.2.x » [WBB 2.2.x] Hacks und Addons » Boardregeln Hack V6 » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag 80.265 Views | | Thema zu Favoriten hinzufügen
Seiten (14): « erste ... « vorherige 5 6 7 8 9 10 11 12 13 [14]
Neues Thema erstellen Antwort erstellen

Zum Ende der Seite springen Boardregeln Hack V6 11 Bewertungen - Durchschnitt: 5,82
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »
Luzifer69
Mitglied


Dabei seit: 30.11.04
Beiträge: 790

Antworten Zitieren Editieren Melden       UP

schau mal eine seite zurück (seite12)
3. post da ist nen link von mir
da klickste drauf dann haste ne anleitung wie man das berichtigt
hab auch gerade bei woltlab drauf geantwortet

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Luzifer69: 04.02.09 19:12.

04.02.09 19:12 Luzifer69 ist offline WWW Finden Als Freund hinzufügen
wotan88
Mitglied


Dabei seit: 11.03.08
Beiträge: 12
Forenversion: 2.3

Antworten Zitieren Editieren Melden       UP

danke dir, werde ich dann mal testen.
04.02.09 19:43 wotan88 ist offline E-Mail Finden Als Freund hinzufügen
pehu
unregistriert
Antworten Zitieren Editieren Melden       UP

Zitat:
Original von pehu
Hallo, mal 'ne Frage. Ich habe den Hack in meinem Board eingebaut und finde ihn echt klasse. Danke dafür. Ich habe aber schon einen anderen Hack drin, bei denen User während der Registrierung die Board-Regeln akzeptieren müssen, sonst kommen sie nicht weiter. Deshalb meine Frage, gibt es eine Möglichkeit, das neue User die Seite nicht angezeigt bekommen?

Nachtrag: Neue User werden nach der Registrierung ja auf einen Willkommensthread geleitet. Jetzt werden sie aber nach dem Fenster immer auf die Startseite (Bei mir Portalseite) geleitet. Auch nicht so toll.

Bin dabei, mein Forum neu aufzubauen und habe mir bei der Gelegenheit den Hack, den ich ja immer noch gut finde, genauer angesehen und das Problem mit der Registrierung gelöst.
05.10.09 22:29
Agi Agi ist männlich
TEAM - PHP Freak

images/avatars/avatar-5240.gif

Dabei seit: 22.11.04
Beiträge: 2.628
Fähigkeiten: WBB3 Profi
Forenversion: 3.1

Antworten Zitieren Editieren Melden       UP

Könntest du deine Lösung bitte noch posten? Damit andere User, die das Problem auch haben, ebenfalls wissen, wie sie es lösen können?

Danke Augenzwinkern

__________________

06.10.09 00:04 Agi ist offline Finden Als Freund hinzufügen
pehu
unregistriert
Antworten Zitieren Editieren Melden       UP

Ach so, na klar.

Man öffne die Setup.php und suche:

php:
1:
$db->query("ALTER TABLE bb".$n."_users ADD `readrules` int(11) NOT NULL default '0'");

Ist Zeile 85.

das default '0'" ändert man in die 1. Die Zeile sollte dann so aussehen:

php:
1:
$db->query("ALTER TABLE bb".$n."_users ADD `readrules` int(11) NOT NULL default '1'");


Das bewirkt, das neue User, die sich registrieren in der Datenbank eine 1 bekommen (neue Regeln schon akzeptiert - Bei mir ja auf der Registrierseite). Und so werden sie dann automagisch auf den Willkommensthread umgeleitet.

Wer den Hack schon eingebaut hat, kann das auch nachträglich in PhpMyAdmin oder im ACP -> SQL Abfragen ändern. Mit dem Befehl:
php:
1:
ALTER TABLE `bb1_usersCHANGE COLUMN `readrules` `readrulesINT(11NOT NULL DEFAULT '1' ;
06.10.09 00:21
Luzifer69
Mitglied


Dabei seit: 30.11.04
Beiträge: 790

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von pehu
Wer den Hack schon eingebaut hat, kann das auch nachträglich in PhpMyAdmin oder im ACP -> SQL Abfragen ändern. Mit dem Befehl:
--> falsche abfrage<--


das wird bestimmt nicht funtionieren
wem seine daten bank heist schon wbb1 ?
somit kommt folglich dann eine fehlermeldung in der art
datenbank nicht gefunden oder sowas in der richtung
berichtige mal die abfrage

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von Luzifer69: 06.10.09 16:02.

06.10.09 16:01 Luzifer69 ist offline WWW Finden Als Freund hinzufügen
Agi Agi ist männlich
TEAM - PHP Freak

images/avatars/avatar-5240.gif

Dabei seit: 22.11.04
Beiträge: 2.628
Fähigkeiten: WBB3 Profi
Forenversion: 3.1

Antworten Zitieren Editieren Melden       UP

Hab sie mal korrigiert. Sollte so nun stimmen.

__________________

06.10.09 17:01 Agi ist offline Finden Als Freund hinzufügen
pehu
unregistriert
Antworten Zitieren Editieren Melden       UP

Sorry, mir fiel gerade ein, dass das ja der Name der Db vom lokalem Testboard ist. Mauer

Dieser Beitrag wurde 2 mal editiert, zum letzten Mal von pehu: 06.10.09 17:11.

06.10.09 17:04
Agi Agi ist männlich
TEAM - PHP Freak

images/avatars/avatar-5240.gif

Dabei seit: 22.11.04
Beiträge: 2.628
Fähigkeiten: WBB3 Profi
Forenversion: 3.1

Antworten Zitieren Editieren Melden       UP

Zitat:
Original von pehu
Danke. Bei mir klappte es aber so.


Ja, weil deine Datenbank ja auch "wbb1" heißt - aber wenn andere User diese Abfrage ausführen, kriegen sie ne Fehlermeldung, weil ihre Datenbank nicht wbb1 heißt.

Wenn man den DB-Namen vorne ganz weg lässt, sollte es bei allen funktionieren.

__________________

06.10.09 17:09 Agi ist offline Finden Als Freund hinzufügen
pehu
unregistriert
Antworten Zitieren Editieren Melden       UP

Ja, habe den Fehler gerade bemerkt und die Antwort von mir geändert.
06.10.09 17:12
Seiten (14): « erste ... « vorherige 5 6 7 8 9 10 11 12 13 [14] Baumstruktur | Brettstruktur
Gehe zu:

Neues Thema erstellen Antwort erstellen

yourWBB » WoltLab Burning Board Generation 2 * » Alles von und für das WBB 2.2.x » [WBB 2.2.x] Hacks und Addons » Boardregeln Hack V6